Instant Debit Card Transfers Experiencing Degraded Performance
Incident Report for DailyPay
Resolved
DailyPay is processing instant payments as expected again. Thanks for bearing with us.
Posted Jun 21, 2023 - 16:56 EDT
Investigating
DailyPay is currently seeing intermittent delays processing instant payments. This will not affect your upcoming payday. We will continue to provide updates as we have them.
Posted Jun 21, 2023 - 15:57 EDT
This incident affected: Payment Methods (Instant Debit Card Transfers).