Direct Deposit Delay for Some Users

Incident Report for DailyPay

Resolved

DailyPay is processing direct deposits to user accounts as expected again.
Posted Nov 13, 2023 - 08:13 EST

Monitoring

The impacted users have been notified. We will continue to monitor.
Posted Nov 10, 2023 - 23:16 EST

Update

Resolution in progress estimated to be complete this evening.
Posted Nov 10, 2023 - 19:23 EST

Update

We are continuing to work on this issue for the impacted users. No-fee instant transfers through Sunday for users waiting on today’s paycheck. We’re still working to get everyone paid in full ASAP. Check back here for further updates.
Posted Nov 10, 2023 - 15:13 EST

Update

We are continuing to work on this issue for the impacted users. No-fee instant transfers through Sunday for users waiting on today’s paycheck. We’re still working to get everyone paid in full ASAP. Check back here for updates.
Posted Nov 10, 2023 - 14:44 EST

Identified

The issue has been identified regarding direct deposits for users. We're still working to resolve this issue as quickly as possible. Check back here for updates. We truly appreciate your patience.
Posted Nov 10, 2023 - 12:13 EST

Update

We are continuing to investigate the issue and will provide updates as we have them.
Posted Nov 10, 2023 - 10:20 EST

Investigating

DailyPay is currently experiencing delays to process direct deposits for users, and we're looking into it. We will continue to provide updates as we have them.
Posted Nov 10, 2023 - 09:34 EST
This incident affected: Payment Methods (Direct Deposit).