Scheduled maintenance is complete and DailyPay is fully operational. You can log in as normal, access earnings, and make transfers. Any pending transfers have resumed. Thank you for your patience. If you are still unable to log in, please reach out to our Support team.
Posted Aug 23, 2026 - 02:52 EDT
In progress
DailyPay is currently undergoing scheduled maintenance, and you won't be able to log in to our app, access earnings, or start transfers. The maintenance window runs until 5:00 AM EST. No action is required on your part. Your account, earnings, and pending transfers remain secure and will be available again as soon as maintenance is complete. Thank you for your patience.
Posted Aug 23, 2026 - 01:01 EDT
Update
Maintenance starting in 30 mins!!
DailyPay will be unavailable for scheduled maintenance on Sunday, August 23, from 1:00 AM to 5:00 AM EST. During this window, you will not be able to log in to our app, access earnings, or start transfers. No action is required on your part. Your account, earnings, and pending transfers remain secure, and full access will resume automatically once maintenance concludes. We will send a confirmation closer to the date.
Posted Aug 23, 2026 - 00:31 EDT
Update
REMINDER!!
DailyPay will be unavailable for scheduled maintenance on Sunday, August 23, from 1:00 AM to 5:00 AM EST. During this window, you will not be able to log in to our app, access earnings, or start transfers. No action is required on your part. Your account, earnings, and pending transfers remain secure, and full access will resume automatically once maintenance concludes. We will send a confirmation closer to the date.
Posted Aug 21, 2026 - 10:37 EDT
Scheduled
DailyPay will be unavailable for scheduled maintenance on Sunday, August 23, from 1:00 AM to 5:00 AM EST. During this window, you will not be able to log in to our app, access earnings, or start transfers. No action is required on your part. Your account, earnings, and pending transfers remain secure, and full access will resume automatically once maintenance concludes. We will send a confirmation closer to the date.
Posted Aug 18, 2026 - 17:58 EDT
This scheduled maintenance affected: Web App and Mobile App.